Development Environment Setup

This guide aims to help you set up Collate, edit its source code and export it as .jar files.

If you want to run the GUI version of Collate, follow the guide to set up the Text UI version before moving on to the setup of the GUI version.

Setup Text UI version of Collate

Setup development environment

JDK 8u40 or later

http://www.oracle.com/technetwork/java/javase/downloads/index.html

  1. Click JDK download
  2. Accept the license agreement and download the appropriate installation file

Eclipse Luna or later

Eclipse is the IDE that was used to develop Collate.

https://www.eclipse.org/downloads/

  1. Download “Eclipse IDE for Java Developers”
  2. Extract the contents to whichever folder you want. E.g. C:/eclipse

e(fx)clipse 1.2.0 or later

e(fx)clipse enables you to create new JavaFX FXML projects using Eclipse and start Scene Builder from within the IDE.

http://www.eclipse.org/efxclipse/install.html

Follow the installation instructions in the link above.

Configure development environment

Set Java JDK

  1. In Preferences window, go to Java > Installed JREs
  2. Remove the existing entries

remove-jre

  1. Click Add…
  2. Select Standard VM and click Next

add-jdk-1

  1. Navigate to the folder of your installed JDK

add-jdk-2

  1. Click Finish
  2. Tick the checkbox beside this entry and click Apply

add-jdk-3

  1. Go to Java > Compiler and ensure the Compiler compliance level is at least 1.8

compiler-compliance-level

Import and run Collate

Download the latest release

  1. Navigate to https://github.com/collate/collate/releases
  2. Download and extract the source code of the latest release

download-collate

Import project into Eclipse

  1. In Eclipse, go to File > Import…
  2. Select General > Existing Projects into Workspace and click Next
  3. Select root folder of the extracted source code and click Finish.

import-collate

The default view of the Package Explorer shows the packages in a flat manner. If you want to see packages in a hierarchical manner, click on the downward pointing triangle and change the Package Presentation.

package-view-1 package-view-2

Run Collate

  1. Open Collate.java from the tui package
  2. Click Run Collate.java

run-tui

Export Collate

  1. File > Export…
  2. Select Java > JAR file
  3. Select the src file to be exported and set the export destination

export-tui-1

  1. Click Next 2 times
  2. Set the Main class
  3. Click Finish

export-tui-2

Run exported jar

  1. Open a command window/terminal in the folder of the jar file

For Windows, Shift+Right click in the folder of the jar file and click open command window here.

command-window-shortcut

  1. Enter java -jar collate-tui.jar (replace the filename accordingly)

command-line-collate

Setup GUI version of Collate

Setup development environment

Follow the setup instructions for the TUI version before moving on.

Scene Builder 8.0.0 or later

Scene Builder enables you to arrange components in JavaFX layouts through a GUI.

http://gluonhq.com/open-source/scene-builder/

Download and install Scene Builder using the link above. Do not download the executable jar as it will not work when attempting to open Scene Builder from Eclipse.

Configure development environment

Follow the configuration instructions for the TUI version before moving on.

Set SceneBuilder executable

  1. Go to Window > Preferences
  2. Click on JavaFX tab
  3. Find the SceneBuilder executable. For Windows, it can be found here: C:\Users\<USER>\AppData\Local\SceneBuilder\SceneBuilder.exe
  4. Click Apply

set scene builder

Edit and run Collate

If you’re unsure how to import Collate, see the above instructions.

Edit .fxml files

e(fx)clipse enables you to edit .fxml files using Scene Builder through Eclipse.

  1. Right click on the .fxml file and click Open with SceneBuilder.

open-with-scenebuilder scenebuilder

  1. After you have saved your edits, refresh the project to ensure the latest .fxml files are used.

refresh-project

Run Collate

  1. Open MainApp.java from the gui package
  2. Click Run MainApp.java

run-gui

Export Collate

  1. File > Export…
  2. Select Java > Runnable JAR file

export-gui-1

  1. Select MainApp as the Launch configuration
  2. Set Export destination
  3. Ensure “Package required libraries into generated JAR” is selected
  4. Click Finish

export-gui-2

Run exported jar

For the GUI version, simply double click on the jar file.